Everything old is new again: Sibelius 7 now supports Windows XP

When we released Sibelius 7 last summer, the minimum system requirements jumped significantly: on Mac, we dropped support for Macs with PowerPC processors, and specified Mac OS X 10.6 Snow Leopard as the minimum supported operating system; and on Windows, we dropped support for Windows XP. The changes in requirements on Mac didn’t have much […]